<!DOCTYPE html>
<html lang="en-US" prefix="og: https://ogp.me/ns#">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="https://gmpg.org/xfn/11">
<link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/5.13.1/css/all.min.css">

<title>Thousands Mourn FDNY EMS Lt. Alison Russo-Elling at LI Funeral</title>
<meta name="description" content="Thousands of family, friends, colleagues, and members of emergency departments from across the country came to honor FDNY EMS Lt. Alison Russo-Elling at her funeral on Wednesday, Oct. 5." />
<meta name="robots" content="follow, index, max-snippet:-1, max-video-preview:-1, max-image-preview:large" />
<link rel="canonical" href="https://www.longislandpress.com/2022/10/05/funeral-ems-lt-alison-russo/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Thousands Mourn FDNY EMS Lt. Alison Russo-Elling at LI Funeral" />
<meta property="og:description" content="Thousands of family, friends, colleagues, and members of emergency departments from across the country came to honor FDNY EMS Lt. Alison Russo-Elling at her funeral on Wednesday, Oct. 5." />
<meta property="og:url" content="https://www.longislandpress.com/2022/10/05/funeral-ems-lt-alison-russo/" />
<meta property="og:site_name" content="LI Press" />
<meta property="article:publisher" content="https://www.facebook.com/longislandpress" />
<meta property="article:tag" content="alison russo-elling" />
<meta property="article:tag" content="EMS" />
<meta property="article:tag" content="FDNY" />
<meta property="article:tag" content="Huntington" />
<meta property="article:tag" content="The Daily" />
<meta property="article:section" content="Featured News" />
<meta property="og:updated_time" content="2022-10-05T14:28:49-04:00" />
<meta property="og:image" content="https://www.longislandpress.com/wp-content/uploads/2022/10/Photo-Oct-05-2022-11-24-28-AM-1.jpg" />
<meta property="og:image:secure_url" content="https://www.longislandpress.com/wp-content/uploads/2022/10/Photo-Oct-05-2022-11-24-28-AM-1.jpg" />
<meta property="og:image:width" content="750" />
<meta property="og:image:height" content="500" />
<meta property="og:image:alt" content="alison russo" />
<meta property="og:image:type" content="image/jpeg" />
<meta property="article:published_time" content="2022-10-05T14:07:40-04:00" />
<meta property="article:modified_time" content="2022-10-05T14:28:49-04:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="Thousands Mourn FDNY EMS Lt. Alison Russo-Elling at LI Funeral" />
<meta name="twitter:description" content="Thousands of family, friends, colleagues, and members of emergency departments from across the country came to honor FDNY EMS Lt. Alison Russo-Elling at her funeral on Wednesday, Oct. 5." />
<meta name="twitter:site" content="@longislandpress" />
<meta name="twitter:creator" content="@brianabonfiglio" />
<meta name="twitter:image" content="https://www.longislandpress.com/wp-content/uploads/2022/10/Photo-Oct-05-2022-11-24-28-AM-1.jpg" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Briana Bonfiglio" />
<meta name="twitter:label2" content="Time to read" />
<meta name="twitter:data2" content="2 minutes" />
<script type="application/ld+json" class="rank-math-schema-pro">{"@context":"https://schema.org","@graph":[{"@type":["NewsMediaOrganization","Organization"],"@id":"https://www.longislandpress.com/#organization","name":"LI Press","url":"https://www.longislandpress.com"},{"@type":"WebSite","@id":"https://www.longislandpress.com/#website","url":"https://www.longislandpress.com","name":"LI Press","publisher":{"@id":"https://www.longislandpress.com/#organization"},"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.longislandpress.com/wp-content/uploads/2022/10/Photo-Oct-05-2022-11-24-28-AM-1.jpg","url":"https://www.longislandpress.com/wp-content/uploads/2022/10/Photo-Oct-05-2022-11-24-28-AM-1.jpg","width":"750","height":"500","inLanguage":"en-US"},{"@type":"Person","@id":"https://www.longislandpress.com/author/briana-bonfiglio/","name":"Briana Bonfiglio","url":"https://www.longislandpress.com/author/briana-bonfiglio/","image":{"@type":"ImageObject","@id":"https://www.longislandpress.com/wp-content/uploads/2022/06/22220611_155383441718607_2062982502913409024_n.jpg","url":"https://www.longislandpress.com/wp-content/uploads/2022/06/22220611_155383441718607_2062982502913409024_n.jpg","caption":"Briana Bonfiglio","inLanguage":"en-US"},"sameAs":["https://twitter.com/brianabonfiglio"],"worksFor":{"@id":"https://www.longislandpress.com/#organization"}},{"@type":"WebPage","@id":"https://www.longislandpress.com/2022/10/05/funeral-ems-lt-alison-russo/#webpage","url":"https://www.longislandpress.com/2022/10/05/funeral-ems-lt-alison-russo/","name":"Thousands Mourn FDNY EMS Lt. Alison Russo-Elling at LI Funeral","datePublished":"2022-10-05T14:07:40-04:00","dateModified":"2022-10-05T14:28:49-04:00","author":{"@id":"https://www.longislandpress.com/author/briana-bonfiglio/"},"isPartOf":{"@id":"https://www.longislandpress.com/#website"},"primaryImageOfPage":{"@id":"https://www.longislandpress.com/wp-content/uploads/2022/10/Photo-Oct-05-2022-11-24-28-AM-1.jpg"},"inLanguage":"en-US"},{"@type":"NewsArticle","headline":"Thousands Mourn FDNY EMS Lt. Alison Russo-Elling at LI Funeral","keywords":"alison russo,FDNY EMS","datePublished":"2022-10-05T14:07:40-04:00","dateModified":"2022-10-05T14:28:49-04:00","author":{"@id":"https://www.longislandpress.com/author/briana-bonfiglio/"},"publisher":{"@id":"https://www.longislandpress.com/#organization"},"description":"Thousands of family, friends, colleagues, and members of emergency departments from across the country came to honor FDNY EMS Lt. Alison Russo-Elling at her funeral on Wednesday, Oct. 5.","copyrightYear":"2022","copyrightHolder":{"@id":"https://www.longislandpress.com/#organization"},"name":"Thousands Mourn FDNY EMS Lt. Alison Russo-Elling at LI Funeral","@id":"https://www.longislandpress.com/2022/10/05/funeral-ems-lt-alison-russo/#richSnippet","isPartOf":{"@id":"https://www.longislandpress.com/2022/10/05/funeral-ems-lt-alison-russo/#webpage"},"image":{"@id":"https://www.longislandpress.com/wp-content/uploads/2022/10/Photo-Oct-05-2022-11-24-28-AM-1.jpg"},"inLanguage":"en-US","mainEntityOfPage":{"@id":"https://www.longislandpress.com/2022/10/05/funeral-ems-lt-alison-russo/#webpage"}}]}</script>

<link rel='dns-prefetch' href='//static.addtoany.com' />
<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//cdn.datatables.net' />
<link rel='dns-prefetch' href='//www.google.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.longislandpress.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0.2"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://www.longislandpress.com/wp-includes/css/dist/block-library/style.min.css?ver=6.0.2' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='jquery-datatables-css' href='https://cdn.datatables.net/1.10.20/css/jquery.dataTables.min.css?ver=6.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='datatables-buttons-css' href='https://cdn.datatables.net/buttons/1.6.1/css/buttons.dataTables.min.css?ver=6.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='datatables-select-css' href='https://cdn.datatables.net/select/1.3.1/css/select.dataTables.min.css?ver=6.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='datatables-fixedheader-css' href='https://cdn.datatables.net/fixedheader/3.1.6/css/fixedHeader.dataTables.min.css?ver=6.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='datatables-fixedcolumns-css' href='https://cdn.datatables.net/fixedcolumns/3.3.0/css/fixedColumns.dataTables.min.css?ver=6.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='datatables-responsive-css' href='https://cdn.datatables.net/responsive/2.2.3/css/responsive.dataTables.min.css?ver=6.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='schneps-rest-post-pusher-css' href='https://www.longislandpress.com/wp-content/plugins/schneps-rest-post-pusher/public/css/schneps-rest-post-pusher-public.css?ver=3.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css' href='https://www.longislandpress.com/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.16' type='text/css' media='all' />
<link rel='stylesheet' id='theme-css-css' href='https://www.longislandpress.com/wp-content/themes/schnepstheme/build/main.12da1f43c821a6a8dffa.css' type='text/css' media='all' />
<style id='theme-css-inline-css' type='text/css'>
header .hamburger{display:flex}@media screen and (max-width:1520px){
					nav.main-nav ul.nav-menu-items .nav-0{display:none}
				}
				@media screen and (max-width:1923px){
					.scrolledDown nav.main-nav ul.nav-menu-items .nav-0{display:none}
				}
				@media screen and (max-width:1404px){
					nav.main-nav ul.nav-menu-items .nav-1{display:none}
				}
				@media screen and (max-width:1807px){
					.scrolledDown nav.main-nav ul.nav-menu-items .nav-1{display:none}
				}
				@media screen and (max-width:1288px){
					nav.main-nav ul.nav-menu-items .nav-2{display:none}
				}
				@media screen and (max-width:1691px){
					.scrolledDown nav.main-nav ul.nav-menu-items .nav-2{display:none}
				}
				@media screen and (max-width:1172px){
					nav.main-nav ul.nav-menu-items .nav-3{display:none}
				}
				@media screen and (max-width:1575px){
					.scrolledDown nav.main-nav ul.nav-menu-items .nav-3{display:none}
				}
				@media screen and (max-width:1056px){
					nav.main-nav ul.nav-menu-items .nav-4{display:none}
				}
				@media screen and (max-width:1459px){
					.scrolledDown nav.main-nav ul.nav-menu-items .nav-4{display:none}
				}
				@media screen and (max-width:940px){
					nav.main-nav ul.nav-menu-items .nav-5{display:none}
				}
				@media screen and (max-width:1343px){
					.scrolledDown nav.main-nav ul.nav-menu-items .nav-5{display:none}
				}
				@media screen and (max-width:824px){
					nav.main-nav ul.nav-menu-items .nav-6{display:none}
				}
				@media screen and (max-width:1227px){
					.scrolledDown nav.main-nav ul.nav-menu-items .nav-6{display:none}
				}
				@media screen and (max-width:708px){
					nav.main-nav ul.nav-menu-items .nav-7{display:none}
				}
				@media screen and (max-width:1111px){
					.scrolledDown nav.main-nav ul.nav-menu-items .nav-7{display:none}
				}
				@media screen and (max-width:592px){
					nav.main-nav ul.nav-menu-items .nav-8{display:none}
				}
				@media screen and (max-width:995px){
					.scrolledDown nav.main-nav ul.nav-menu-items .nav-8{display:none}
				}
				@media screen and (max-width:476px){
					nav.main-nav ul.nav-menu-items .nav-9{display:none}
				}
				@media screen and (max-width:879px){
					.scrolledDown nav.main-nav ul.nav-menu-items .nav-9{display:none}
				}
				@media screen and (max-width:360px){
					nav.main-nav ul.nav-menu-items .nav-10{display:none}
				}
				@media screen and (max-width:763px){
					.scrolledDown nav.main-nav ul.nav-menu-items .nav-10{display:none}
				}
				
</style>
<link rel='stylesheet' id='child-theme-css-css' href='https://www.longislandpress.com/wp-content/themes/schnepstheme-lipress/build/main.53c2c215862f051bbe24.css' type='text/css' media='all' />
<script type='text/javascript' id='addtoany-core-js-before'>
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
</script>
<script type='text/javascript' async src='https://static.addtoany.com/menu/page.js' id='addtoany-core-js'></script>
<script type='text/javascript' src='https://www.longislandpress.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.longislandpress.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' async src='https://www.longislandpress.com/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1' id='addtoany-jquery-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/hammer.js/1.0.5/jquery.hammer.min.js?ver=2.0' id='hammerjs-js'></script>
<script type='text/javascript' src='https://www.longislandpress.com/wp-content/plugins/home-pros-directory/lib/tosrus/jquery.tosrus.min.all.js?ver=2.0' id='TosRUs-js'></script>
<script type='text/javascript' src='https://cdn.datatables.net/1.10.20/js/jquery.dataTables.min.js?ver=6.0.2' id='jquery-datatables-js'></script>
<script type='text/javascript' src='https://cdn.datatables.net/buttons/1.6.1/js/dataTables.buttons.min.js?ver=6.0.2' id='datatables-buttons-js'></script>
<script type='text/javascript' src='//cdn.datatables.net/buttons/1.6.1/js/buttons.colVis.min.js?ver=6.0.2' id='datatables-buttons-colvis-js'></script>
<script type='text/javascript' src='//cdn.datatables.net/buttons/1.6.1/js/buttons.print.min.js?ver=6.0.2' id='datatables-buttons-print-js'></script>
<script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/pdfmake/0.1.53/pdfmake.min.js?ver=6.0.2' id='pdfmake-js'></script>
<script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/pdfmake/0.1.53/vfs_fonts.js?ver=6.0.2' id='pdfmake-fonts-js'></script>
<script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/jszip/3.1.3/jszip.min.js?ver=6.0.2' id='jszip-js'></script>
<script type='text/javascript' src='//cdn.datatables.net/buttons/1.6.1/js/buttons.html5.min.js?ver=6.0.2' id='datatables-buttons-html5-js'></script>
<script type='text/javascript' src='https://cdn.datatables.net/select/1.3.1/js/dataTables.select.min.js?ver=6.0.2' id='datatables-select-js'></script>
<script type='text/javascript' src='https://cdn.datatables.net/fixedheader/3.1.6/js/dataTables.fixedHeader.min.js?ver=6.0.2' id='datatables-fixedheader-js'></script>
<script type='text/javascript' src='https://cdn.datatables.net/fixedcolumns/3.3.0/js/dataTables.fixedColumns.min.js?ver=6.0.2' id='datatables-fixedcolumns-js'></script>
<script type='text/javascript' src='https://cdn.datatables.net/responsive/2.2.3/js/dataTables.responsive.min.js?ver=6.0.2' id='datatables-responsive-js'></script>
<script type='text/javascript' id='igsv-datatables-js-extra'>
/* <![CDATA[ */
var igsv_plugin_vars = {"lang_dir":"https:\/\/www.longislandpress.com\/wp-content\/plugins\/inline-google-spreadsheet-viewer\/languages","datatables_classes":".igsv-table:not(.no-datatables)","datatables_defaults_object":{"dom":"B<'clear'>lfrtip","buttons":["colvis","copy","csv","excel","pdf","print"]}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.longislandpress.com/wp-content/plugins/inline-google-spreadsheet-viewer/igsv-datatables.js?ver=6.0.2' id='igsv-datatables-js'></script>
<script type='text/javascript' src='//www.google.com/jsapi?ver=6.0.2' id='google-ajax-api-js'></script>
<script type='text/javascript' src='https://www.longislandpress.com/wp-content/plugins/inline-google-spreadsheet-viewer/igsv-gvizcharts.js?ver=6.0.2' id='igsv-gvizcharts-js'></script>
<script type='text/javascript' src='https://www.longislandpress.com/wp-content/plugins/schneps-rest-post-pusher/public/js/schneps-rest-post-pusher-public.js?ver=3.0.1' id='schneps-rest-post-pusher-js'></script>
<script type='text/javascript' id='read-more.js-js-extra'>
/* <![CDATA[ */
var pp_vars = {"publisher_id":"b87bb927-c530-47a0-9d7f-10aa1610155f","widget_endpoint":"https:\/\/gadget.pico.tools","plugin_version":"1.0.2","widget_version":"10.05.22.18.28","pico_context":"gadget","post_id":"106559","post_type":"post","post_title":"Thousands Mourn FDNY EMS Lt. Alison Russo-Elling at Long Island Funeral","taxonomies_for_this_post_type":["category","post_tag","post_format","flags","districts","author"],"list_of_taxonomies":["category","post_tag","nav_menu","link_category","post_format","wp_theme","wp_template_part_area","flags","districts","ngg_tag","rank_math_redirection_category","author"],"show_read_more_button":"1","taxonomies":{"category":["featured news"],"post_tag":["alison russo-elling","ems","fdny","huntington","the daily"],"author":["briana bonfiglio"]},"resource_ref":"year=2022&monthnum=10&day=05&name=funeral-ems-lt-alison-russo"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.longislandpress.com/wp-content/plugins/pico/includes/js/read-more.js?ver=10.05.22.18.28' id='read-more.js-js'></script>
<link rel="https://api.w.org/" href="https://www.longislandpress.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.longislandpress.com/wp-json/wp/v2/posts/106559" /><link rel="alternate" type="application/json+oembed" href="https://www.longislandpress.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.longislandpress.com%2F2022%2F10%2F05%2Ffuneral-ems-lt-alison-russo%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.longislandpress.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.longislandpress.com%2F2022%2F10%2F05%2Ffuneral-ems-lt-alison-russo%2F&#038;format=xml" />
<style></style> <link rel="preconnect" href="https://fonts.googleapis.com/" crossorigin>
<link rel="dns-prefetch" href="https://fonts.googleapis.com/">
<link rel="preconnect" href="https://cdnjs.cloudflare.com/" crossorigin>
<link rel="dns-prefetch" href="https://cdnjs.cloudflare.com/">
<link rel="shortcut icon" href="https://www.longislandpress.com/wp-content/uploads/2022/06/LongIslandPress-favicon-circle.png"><link rel="apple-touch-icon-precomposed" href="https://www.longislandpress.com/wp-content/uploads/2022/06/22220611_155383441718607_2062982502913409024_n.jpg"><script type="text/javascript">typeof jQuery!='undefined'&&jQuery(document).ready(function(a){jQuery('a').on('click',function(h){var c=jQuery(this);var d=!0;var b=c.attr('href')!==void 0?c.attr('href'):'';var e=b.replace(/^https?\:\/\//i,'').replace('www.','').split('/')[0];var f=document.domain.replace('www.','');var g=c.attr('target')!==void 0?c.attr('target'):'';if(!b.match(/^javascript:/i)){var a=[];if(a.value=0,a.non_i=!1,b.match(/^https?\:/i)&&e!==f?(a.category='external',a.action='click',a.label=b.replace(/^https?\:\/\//i,''),a.non_i=!0,a.loc=b):d=!1,d)return window._gat?_gaq.push(['_trackEvent',a.category.toLowerCase(),a.action.toLowerCase(),a.label.toLowerCase(),a.value,a.non_i]):ga('send','event',a.category.toLowerCase(),a.action.toLowerCase(),a.label.toLowerCase(),a.value),g=='_blank'?window.open(a.loc):setTimeout(function(){window.location.href=a.loc;},400),window.console&&window.console.log&&console.log('Outbound: '+a.label),!1;}});});</script>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-8564418-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-8564418-1');
</script>
<script>var clicky_site_ids = clicky_site_ids || []; clicky_site_ids.push(101168453);</script>
<script async src="//static.getclicky.com/js"></script>

<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-b9L3JGn1-4d-_"
});
</script>
<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-b9L3JGn1-4d-_.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>

<meta name="theme-color" content="#4DB2EC">
<meta name="facebook-domain-verification" content="pyzlr4ewm2ee58w66iipkvjgkh06va" />

<script src="https://cdn01.basis.net/assets/up.js?um=1"></script>
<script type="text/javascript">
        cntrUpTag.track('cntrData', '5802d34a4c88ff78');
</script>
<script type="text/javascript" async="async" src="//widgets.outbrain.com/outbrain.js"></script>
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
  googletag.cmd.push(function() {

	/* Category Ad Targeting */
        googletag.pubads().setTargeting("SCKeyword", ["featured-news","alison-russo-elling","ems","fdny","huntington","the-daily","post-106559"]);

/*
googletag.defineSlot('/1048906/sponsored_lipress_desktop', [600, 250], 'div-gpt-ad-1595436214888-0').addService(googletag.pubads());
googletag.defineSlot('/1048906/sponsored_lipress_mobile', [300, 250], 'div-gpt-ad-1595436214888-1').addService(googletag.pubads());
googletag.defineSlot('/1048906/sponsored_lipress_tablet', [728, 250], 'div-gpt-ad-1595436214888-2').addService(googletag.pubads());

googletag.defineSlot('/1048906/LICP-Leader', [1068, 250], 'div-gpt-ad-1494278047564-2').addService(googletag.pubads());
*/

googletag.defineSlot('/1048906/LICP-300x250', [300, 250], 'div-gpt-ad-1494278047564-0').addService(googletag.pubads());
googletag.defineSlot('/1048906/LICP-300x250-2', [300, 250], 'div-gpt-ad-1494278047564-1').addService(googletag.pubads());
googletag.defineSlot('/1048906/LIP-728x90-T', [728, 90], 'div-gpt-ad-1494858715156-1').addService(googletag.pubads());
googletag.defineSlot('/1048906/LIP-320x50', [320, 50], 'div-gpt-ad-1494858715156-0').addService(googletag.pubads());
googletag.defineSlot('/1048906/LICP-Leader', [970, 90], 'div-gpt-ad-1536266236357-0').addService(googletag.pubads());
googletag.defineSlot('/1048906/LICPMobile320x50', [320, 50], 'div-gpt-ad-1541619168484-0').addService(googletag.pubads());
googletag.defineSlot('/1048906/LIPress_tower', [300, 600], 'div-gpt-ad-1591291514378-0').addService(googletag.pubads());
googletag.defineSlot('/1048906/LIPress-1x1', [1, 1], 'div-gpt-ad-1547068129808-0').addService(googletag.pubads());


    googletag.pubads().enableSingleRequest();
googletag.pubads().collapseEmptyDivs(true);    googletag.enableServices();
  });
</script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-6749561928889346",
    enable_page_level_ads: true
  });
</script></head>
<body class="post-template-default single single-post postid-106559 single-format-standard singular theme-child-schnepstheme-lipress funeral-ems-lt-alison-russo">
<div id="spotim-data" data-src="https://launcher.spot.im/spot/sp_FtmIajT5" data-spotim-module="spotim-launcher" data-post-url="https://www.longislandpress.com/2022/10/05/funeral-ems-lt-alison-russo/" data-article-tags="Featured News" data-post-id="106559" data-spotim-autorun="false">
</div>
<div id="grid-wrapper" class="PicoSignal">
<div class="ad-container header-ad-container">

<div id='div-gpt-ad-1536266236357-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1536266236357-0'); });
</script>
</div>
</div>
<div class="potential-overlay-container standard-header-container">
<div class="potential-overlay standard-header">
<div class="header-wrapper">
<header class="header-standard site-masthead">
<div class="magazines-container">
<a href="/category/digital-editions">
<span class="the-cover"><img src="https://www.longislandpress.com/wp-content/uploads/2022/09/long-island-press-october-1-2022-238x300.jpg" width="400" height="475" alt="Newspaper cover"></span>
<h4 style="z-index: 10;margin-left: -32px;background: rgba(255,255,255,1);padding: 5px 10px 9px;"><i class="fas fa-newspaper"></i>Flip through <br> the latest issue</h4>
</a>
</div>
<div class="logo-container">
<a href="/"><img src="https://www.longislandpress.com/wp-content/uploads/2022/06/LongIslandPress_logo.png" alt="LI Press: Get the latest Long Island News from the Long Island Press. Featuring unique and thorough coverage of arts and entertainment, sports and politics." class="fullLogo" width="2918" height="362"><img src="https://www.longislandpress.com/wp-content/uploads/2022/06/LongIslandPress_logo_white.png" alt="LI Press: Get the latest Long Island News from the Long Island Press. Featuring unique and thorough coverage of arts and entertainment, sports and politics." class="scrolldownLogo" width="2918" height="362"></a> </div>
<div class="subscribe-container">
<p title="Presented by Bethpage Federal Credit Union" style="margin:0;padding-right:22px;background-image:url(/wp-content/uploads/2022/06/bp.webp);background-repeat:no-repeat;background-position:right;background-size:18px;">Bethpage</p>
<h3 style="margin:0 0 .35rem;"><a href="https://www.bestoflongisland.com/" target="_blank">Best of LI</a></h3>
<a class="basic-button bkg-tert" href="https://www.bestoflongisland.com/nominations/" target="_blank">Nominate</a>
</div>
<div class="hamburger">
<i class="fas fa-bars opener" aria-hidden="true"></i>
<i class="fas fa-times closer" aria-hidden="true"></i>
</div>
</header>
</div>
<div class="nav-container">

<nav class="main-nav static-menu" role="navigation">
<ul class="nav-menu-items">
<li class="nav-menu-item nav-menu-item-basic nav-jobs nav-8">
<a class="nav-menu-link" href="https://jobs.longislandpress.com/" target="_blank"><i class="fas fa-user-tie"></i>Jobs</a>
</li>
<li class="nav-menu-item nav-menu-item-basic nav-home-pros nav-7">
<a class="nav-menu-link" href="/home-pros/"><i class="fas fa-tools"></i>Home Pros</a>
</li>
<li class="nav-menu-item nav-menu-item-basic nav-news nav-6 nav-menu-item-with-submenu menu-opener navigable">
<a class="nav-menu-link" href="/category/featured-news/">News</a>
<ul class="dropdown">
<li><a href="/category/featured-news/">Featured News</a></li>
<li><a href="/category/business/">Business</a></li>
<li><a href="/category/coronavirus/">Coronavirus</a></li>
<li><a href="/category/family/">Family</a></li>
<li><a href="/category/investigations/">Investigations</a></li>
<li><a href="/category/live-well/">Live+Well</a></li>
<li><a href="/category/featured-news/obituaries/">Obituaries</a></li>
<li><a href="/category/opinions/">Opinion</a></li>
<li><a href="/category/pets/">Pets</a></li>
<li><a href="/category/real-estate/">Real Estate</a></li>
</ul>
</li>
<li class="nav-menu-item nav-menu-item-basic nav-local nav-5">
<a class="nav-menu-link" href="/category/local-news/"><i class="fas fa-map-marker-alt"></i>Local</a>
</li>
<li class="nav-menu-item nav-menu-item-basic nav-entertainment nav-4 nav-menu-item-with-submenu menu-opener navigable">
<a class="nav-menu-link" href="/category/entertainment/">Entertainment</a>
<ul class="dropdown">
<li><a href="/category/entertainment/">Entertainment</a></li>
<li><a href="/category/food-drink/">Food & Drink</a></li>
<li><a href="/category/past-present/rear-view/">Local History</a></li>
<li><a href="/category/brain-candy/">Brain Candy</a></li>
<li><a href="/category/scene-seen/">Community News</a></li>
<li><a href="/category/everything-long-island/">Everything LI</a></li>
</ul>
</li>
<li class="nav-menu-item nav-menu-item-basic nav-events nav-3 nav-menu-item-with-submenu menu-opener navigable">
<a class="nav-menu-link">Events</a>
<ul class="dropdown">
<li><a href="https://www.schnepsmedia.com/events/long-island-press-powerlist/">LI Press PowerList</a></li>
<li><a href="https://www.schnepsmedia.com/events/power-women-of-the-east-end/">East End Power Women</a></li>
<li><a href="https://www.schnepsmedia.com/events/power-women-of-long-island/">Power Women of LI</a></li>
<li><a href="https://tastethegreats.com/">Taste the Greats</a></li>
<li><a href="https://www.schnepsmedia.com/events/alist/">The A List</a></li>
<li><a href="/2021/01/10/who-are-the-top-techies-on-long-island/">Top Techie Awards</a></li>
</ul>
</li>
<li class="nav-menu-item nav-menu-item-basic nav-digital-editions nav-2">
<a class="nav-menu-link" href="/category/digital-editions/">Digital Editions</a>
</li>
<li class="nav-menu-item nav-menu-item-basic nav-contact-us nav-1">
<a class="nav-menu-link" href="/contact-us/">Contact Us</a>
</li>
<li class="nav-menu-item nav-menu-item-basic nav-subscribe nav-0">
<a class="nav-menu-link" href="/subscribe/">Subscribe</a>
</li>
</ul>
</nav>
<nav class="corner-nav" role="navigation">
<div class="nav-menu-social-links social-links nav-menu-icon-row">
<a href="https://www.facebook.com/longislandpress" target="_blank" title="Facebook">
<i class="fab fa-facebook-f" aria-hidden="true" aria-label="Facebook"></i></a>
<a href="https://twitter.com/longislandpress" target="_blank" title="Twitter">
<i class="fab fa-twitter" aria-hidden="true" aria-label="Twitter"></i></a>
<a href="https://www.youtube.com/user/longislandpress" target="_blank" title="Youtube">
<i class="fab fa-youtube" aria-hidden="true" aria-label="Youtube"></i></a>
<a href="https://www.instagram.com/longislandpress/" target="_blank" title="Instagram">
<i class="fab fa-instagram" aria-hidden="true" aria-label="Instagram"></i></a>
</div>
<div class="nav-menu-search-newsletter nav-menu-icon-row"><a class="nav-menu-contact" href="/contact-us/"><i class="fas fa-envelope-open-text" aria-hidden="true" aria-label="Contact Us"></i></a></div>
<div class="nav-menu-search-box bkg-main">
<form role="search" method="get" class="search-form" action="/">
<label>
<span class="screen-reader-text">Search:</span>
<input type="search" class="search-field" placeholder="Search" value="" name="s">
</label>
<button type="submit" class="basic-button bkg-main search-submit icon-search-basic" value="Search"><i class="fa fa-search" aria-hidden="true" aria-label="Search"></i></button>
</form> </div>
<div class="hamburger">
<i class="fas fa-bars opener" aria-hidden="true"></i>
<i class="fas fa-times closer" aria-hidden="true"></i>
</div>
</nav>
</div>

</div>
</div>
<div class="potential-overlay-container actual-overlay-container">
<div class="potential-overlay actual-overlay">
<div class="header-wrapper">
<header class="header-standard site-masthead">
<div class="logo-container">
<a href="/"><img src="https://www.longislandpress.com/wp-content/uploads/2022/06/LongIslandPress_logo.png" alt="LI Press: Get the latest Long Island News from the Long Island Press. Featuring unique and thorough coverage of arts and entertainment, sports and politics." class="fullLogo" width="2918" height="362"><img src="https://www.longislandpress.com/wp-content/uploads/2022/06/LongIslandPress_logo_white.png" alt="LI Press: Get the latest Long Island News from the Long Island Press. Featuring unique and thorough coverage of arts and entertainment, sports and politics." class="scrolldownLogo" width="2918" height="362"></a> </div>
<div class="hamburger">
<i class="fas fa-bars opener" aria-hidden="true"></i>
<i class="fas fa-times closer" aria-hidden="true"></i>
</div>
</header>
</div>


<nav class="main-nav hamburger-menu" role="navigation">
<ul class="nav-menu-items nav-menu-singlet">
<li class="hamburger-menu-search-box">
<form role="search" method="get" class="search-form" action="/">
<label>
<span class="screen-reader-text">Search:</span>
<input type="search" class="search-field" placeholder="Search" value="" name="s">
</label>
<button type="submit" class="basic-button bkg-main search-submit icon-search-basic" value="Search"><i class="fa fa-search" aria-hidden="true" aria-label="Search"></i></button>
</form> </li>
</ul>
<div class="hamburger-grid">
<ul class="nav-menu-items nav-menu-pile">
<li class="nav-menu-item nav-menu-subhead">
<a class="nav-menu-link" href="/category/featured-news/">News</a>
</li><li class="nav-menu-item"><a href="/category/featured-news/">Featured News</a></li><li class="nav-menu-item"><a href="/category/business/">Business</a></li><li class="nav-menu-item"><a href="/category/coronavirus/">Coronavirus</a></li><li class="nav-menu-item"><a href="/category/family/">Family</a></li><li class="nav-menu-item"><a href="/category/investigations/">Investigations</a></li></ul><ul class="nav-menu-items nav-menu-pile"><li class="nav-menu-spacer nav-menu-item nav-menu-subhead"><span class="spacer">&nbsp;</span></li><li class="nav-menu-item"><a href="/category/live-well/">Live+Well</a></li><li class="nav-menu-item"><a href="/category/featured-news/obituaries/">Obituaries</a></li><li class="nav-menu-item"><a href="/category/opinions/">Opinion</a></li><li class="nav-menu-item"><a href="/category/pets/">Pets</a></li><li class="nav-menu-item"><a href="/category/real-estate/">Real Estate</a></li></ul><ul class="nav-menu-items nav-menu-pile">
<li class="nav-menu-item nav-menu-subhead">
<a class="nav-menu-link" href="/category/entertainment/">Entertainment</a>
</li><li class="nav-menu-item"><a href="/category/entertainment/">Entertainment</a></li><li class="nav-menu-item"><a href="/category/food-drink/">Food & Drink</a></li><li class="nav-menu-item"><a href="/category/past-present/rear-view/">Local History</a></li><li class="nav-menu-item"><a href="/category/brain-candy/">Brain Candy</a></li><li class="nav-menu-item"><a href="/category/scene-seen/">Community News</a></li><li class="nav-menu-item"><a href="/category/everything-long-island/">Everything LI</a></li></ul><ul class="nav-menu-items nav-menu-pile">
<li class="nav-menu-item nav-menu-subhead">
<a class="nav-menu-link" href="/">Events</a>
</li><li class="nav-menu-item"><a href="https://www.schnepsmedia.com/events/long-island-press-powerlist/">LI Press PowerList</a></li><li class="nav-menu-item"><a href="https://www.schnepsmedia.com/events/power-women-of-the-east-end/">East End Power Women</a></li><li class="nav-menu-item"><a href="https://www.schnepsmedia.com/events/power-women-of-long-island/">Power Women of LI</a></li><li class="nav-menu-item"><a href="https://tastethegreats.com/">Taste the Greats</a></li><li class="nav-menu-item"><a href="https://www.schnepsmedia.com/events/alist/">The A List</a></li><li class="nav-menu-item"><a href="/2021/01/10/who-are-the-top-techies-on-long-island/">Top Techie Awards</a></li></ul><ul class="nav-menu-items nav-menu-pile nav-menu-singlet-group">
<li class="nav-menu-item nav-menu-subhead">
<a class="nav-menu-link" href="https://jobs.longislandpress.com/" target="_blank"><i class="fas fa-user-tie"></i>Jobs</a>
</li>
<li class="nav-menu-item nav-menu-subhead">
<a class="nav-menu-link" href="/home-pros/"><i class="fas fa-tools"></i>Home Pros</a>
</li>
<li class="nav-menu-item nav-menu-subhead">
<a class="nav-menu-link" href="/category/local-news/"><i class="fas fa-map-marker-alt"></i>Local</a>
</li>
<li class="nav-menu-item nav-menu-subhead">
<a class="nav-menu-link" href="/category/digital-editions/">Digital Editions</a>
</li>
<li class="nav-menu-item nav-menu-subhead">
<a class="nav-menu-link" href="/contact-us/">Contact Us</a>
</li>
<li class="nav-menu-item nav-menu-subhead">
<a class="nav-menu-link" href="/subscribe/">Subscribe</a>
</li>
<ul class="nav-menu-items">
<li class="nav-menu-social-links social-links nav-menu-icon-row">
<a href="https://www.facebook.com/longislandpress" target="_blank" title="Facebook">
<i class="fab fa-facebook-f" aria-hidden="true" aria-label="Facebook"></i></a>
<a href="https://twitter.com/longislandpress" target="_blank" title="Twitter">
<i class="fab fa-twitter" aria-hidden="true" aria-label="Twitter"></i></a>
<a href="https://www.youtube.com/user/longislandpress" target="_blank" title="Youtube">
<i class="fab fa-youtube" aria-hidden="true" aria-label="Youtube"></i></a>
<a href="https://www.instagram.com/longislandpress/" target="_blank" title="Instagram">
<i class="fab fa-instagram" aria-hidden="true" aria-label="Instagram"></i></a>
</li>
</ul>
</ul>
</div>
</nav>
</div>
</div>
<div class="content-container single-template transparent-container wallpaper-container">
<div class="container-center-cut">
<div class="content-section standard-singlepost">
<div class="content-main">
<article id="post-106559" class="post-106559 post type-post status-publish format-standard has-post-thumbnail hentry category-featured-news tag-alison-russo-elling tag-ems tag-fdny tag-huntington tag-the-daily">
<div class="article-header">
<div class="category-box category-label category-label-featured-news">
<a href="https://www.longislandpress.com/category/featured-news/">Featured News</a>
</div>
<h1 class="article-title">Thousands Mourn FDNY EMS Lt. Alison Russo-Elling at Long Island Funeral</h1>
<div class="article-meta triple">
<span class="byline"><img alt='' src='https://www.longislandpress.com/wp-content/uploads/2022/06/22220611_155383441718607_2062982502913409024_n.jpg' srcset='https://www.longislandpress.com/wp-content/uploads/2022/06/22220611_155383441718607_2062982502913409024_n.jpg 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy' /><span class="name">By <a href="https://www.longislandpress.com/author/briana-bonfiglio/" title="Posts by Briana Bonfiglio" class="author url fn" rel="author">Briana Bonfiglio</a></span></span>
<div class="comments-meta spotim-commentscount"><a class="comments-opener comments-count" href="https://www.longislandpress.com/2022/10/05/funeral-ems-lt-alison-russo/?comments=show" rel="nofollow"><i class="far fa-comment-alt"></i> comments</a></div>
<span class="posted-on"><span class="intro">Posted on </span><a href="https://www.longislandpress.com/2022/10/05/funeral-ems-lt-alison-russo/" rel="bookmark"><time class="entry-date published updated" datetime="2022-10-05T14:07:40-04:00">October 5, 2022</time></a></span>
</div>
</div>

<div class="post-thumbnail">
<div class="image-wrapper">
<div class="image-backstop" style="background-image:url('https://www.longislandpress.com/wp-content/uploads/2022/10/Photo-Oct-05-2022-11-24-28-AM-1-150x150.jpg');"></div>
<img width="750" height="500" src="https://www.longislandpress.com/wp-content/uploads/2022/10/Photo-Oct-05-2022-11-24-28-AM-1.jpg" class="crop-center wp-post-image" alt="Photo Oct 05 2022, 11 24 28 AM (1)" srcset="https://www.longislandpress.com/wp-content/uploads/2022/10/Photo-Oct-05-2022-11-24-28-AM-1.jpg 750w, https://www.longislandpress.com/wp-content/uploads/2022/10/Photo-Oct-05-2022-11-24-28-AM-1-300x200.jpg 300w, https://www.longislandpress.com/wp-content/uploads/2022/10/Photo-Oct-05-2022-11-24-28-AM-1-384x256.jpg 384w" sizes="(max-width: 750px) 100vw, 750px" /> </div>
<div class="image-caption">Alison Russo-Elling&#8217;s casket was brought to the Tilles Center in Brookville in an FDNY ambulance with her name on it.</div> <div class="image-credit">Photo by Lloyd Mitchell</div></div>
<div class="addthis_inline_share_toolbox"></div>
<div class="article-content">
<figure class="promo-oneliner newsletter"><span style="margin-right: .1rem; color: #ccc;"><i class="far fa-envelope" aria-hidden="true"></i></span> <span>Sign up for our <a href="https://www.amny.com/sports-newsletter-signup/?utm_source=amny&utm_medium=oneliner&utm_campaign=amnysportsnewsletter" target="_blank">amNY Sports email newsletter</a> to get insights and game coverage for your favorite teams</span></figure><div class="addtoany_share_save_container addtoany_content addtoany_content_top"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.longislandpress.com/2022/10/05/funeral-ems-lt-alison-russo/" data-a2a-title="Thousands Mourn FDNY EMS Lt. Alison Russo-Elling at Long Island Funeral"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.longislandpress.com%2F2022%2F10%2F05%2Ffuneral-ems-lt-alison-russo%2F&amp;linkname=Thousands%20Mourn%20FDNY%20EMS%20Lt.%20Alison%20Russo-Elling%20at%20Long%20Island%20Funeral" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.longislandpress.com%2F2022%2F10%2F05%2Ffuneral-ems-lt-alison-russo%2F&amp;linkname=Thousands%20Mourn%20FDNY%20EMS%20Lt.%20Alison%20Russo-Elling%20at%20Long%20Island%20Funeral" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_printfriendly" href="https://www.addtoany.com/add_to/printfriendly?linkurl=https%3A%2F%2Fwww.longislandpress.com%2F2022%2F10%2F05%2Ffuneral-ems-lt-alison-russo%2F&amp;linkname=Thousands%20Mourn%20FDNY%20EMS%20Lt.%20Alison%20Russo-Elling%20at%20Long%20Island%20Funeral" title="PrintFriendly" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div><div id="pico"><p><span style="font-weight: 400;">Thousands of family, friends, colleagues, and members of emergency departments from across the country came to honor FDNY EMS Lt. Alison Russo-Elling at her funeral on Wednesday, Oct. 5.</span></p>
<p><span style="font-weight: 400;">The 61-year-old Huntington resident was killed in the line of duty on Sept. 29. A volunteer with the Huntington First Aid Squad for 30 years, a 25-year veteran with the FDNY, and a 9/11 first responder, she was posthumously promoted to FDNY EMS captain during the ceremony at the Tilles Center for Performing Arts on the LIU Post campus in Brookville.</span></p>
<p><span style="font-weight: 400;">“Our EMS members are known for being the best. Lt. Alison Russo exemplified the best of our best,” said FDNY Acting Fire Commissioner Laura Kavanaugh. “She lived a truly remarkable life. She was so dedicated and passionate about her work that she did it in her free time, too, as a volunteer, friend, and mentor.”</span></p>
<figure id="attachment_106561" aria-describedby="caption-attachment-106561" style="max-width: 2560px" class="wp-caption alignnone"><img loading="lazy" class="size-full wp-image-106561" src="https://www.longislandpress.com/wp-content/uploads/2022/10/FuneralRusso_Holtermann-2-scaled.jpg" alt="alison russo fdny ems" width="2560" height="1708" srcset="https://www.longislandpress.com/wp-content/uploads/2022/10/FuneralRusso_Holtermann-2-scaled.jpg 2560w, https://www.longislandpress.com/wp-content/uploads/2022/10/FuneralRusso_Holtermann-2-300x200.jpg 300w, https://www.longislandpress.com/wp-content/uploads/2022/10/FuneralRusso_Holtermann-2-1024x683.jpg 1024w, https://www.longislandpress.com/wp-content/uploads/2022/10/FuneralRusso_Holtermann-2-768x513.jpg 768w, https://www.longislandpress.com/wp-content/uploads/2022/10/FuneralRusso_Holtermann-2-1536x1025.jpg 1536w, https://www.longislandpress.com/wp-content/uploads/2022/10/FuneralRusso_Holtermann-2-2048x1367.jpg 2048w, https://www.longislandpress.com/wp-content/uploads/2022/10/FuneralRusso_Holtermann-2-384x256.jpg 384w, https://www.longislandpress.com/wp-content/uploads/2022/10/FuneralRusso_Holtermann-2-900x601.jpg 900w, https://www.longislandpress.com/wp-content/uploads/2022/10/FuneralRusso_Holtermann-2-1600x1068.jpg 1600w" sizes="(max-width: 2560px) 100vw, 2560px" /><figcaption id="caption-attachment-106561" class="wp-caption-text"><span class="image-caption">FDNY members gather for Alison Russo-Elling&#8217;s funeral</span><span class="image-credit">Photo by Gabriele Holtermann</span></figcaption></figure>
<p><span style="font-weight: 400;">She was the “rock” of her family and “mother hen” of her work family at FDNY Station 49 in Queens, her loved ones said in their eulogies. Her brother, Craig Fuoco, and daughter, Danielle Fuoco, spoke during the service, as well as New York City Mayor Eric Adams and several of her colleagues. Her father, Frank Fuoco, also spoke on behalf of himself and her mother, Catherine Fuoco.</span></p>
<p><span style="font-weight: 400;">“There are countless people still walking this earth thanks to Alison and her dedication to her job,” Craig said. “I was proud of my big sister and all of her work accomplishments, particularly during 9/11 and her promotion to lieutenant.”</span></p>
<p><span style="font-weight: 400;">Craig added that his children called their Aunt Alison “a rescue hero, which is exactly what she was.”</span></p>
<figure id="attachment_106562" aria-describedby="caption-attachment-106562" style="max-width: 2560px" class="wp-caption alignnone"><img loading="lazy" class="size-full wp-image-106562" src="https://www.longislandpress.com/wp-content/uploads/2022/10/Photo-Oct-05-2022-11-07-38-AM-scaled.jpg" alt="Photo Oct 05 2022 11 07 38 AM scaled" width="2560" height="1707" srcset="https://www.longislandpress.com/wp-content/uploads/2022/10/Photo-Oct-05-2022-11-07-38-AM-scaled.jpg 2560w, https://www.longislandpress.com/wp-content/uploads/2022/10/Photo-Oct-05-2022-11-07-38-AM-300x200.jpg 300w, https://www.longislandpress.com/wp-content/uploads/2022/10/Photo-Oct-05-2022-11-07-38-AM-1024x683.jpg 1024w, https://www.longislandpress.com/wp-content/uploads/2022/10/Photo-Oct-05-2022-11-07-38-AM-768x512.jpg 768w, https://www.longislandpress.com/wp-content/uploads/2022/10/Photo-Oct-05-2022-11-07-38-AM-1536x1024.jpg 1536w, https://www.longislandpress.com/wp-content/uploads/2022/10/Photo-Oct-05-2022-11-07-38-AM-2048x1365.jpg 2048w, https://www.longislandpress.com/wp-content/uploads/2022/10/Photo-Oct-05-2022-11-07-38-AM-384x256.jpg 384w, https://www.longislandpress.com/wp-content/uploads/2022/10/Photo-Oct-05-2022-11-07-38-AM-900x600.jpg 900w, https://www.longislandpress.com/wp-content/uploads/2022/10/Photo-Oct-05-2022-11-07-38-AM-1600x1067.jpg 1600w" sizes="(max-width: 2560px) 100vw, 2560px"><figcaption id="caption-attachment-106562" class="wp-caption-text"><span class="image-caption">Acting FDNY Commissioner Laura Kavanagh and New York City Mayor Eric Adams spoke at the funeral</span><span class="image-credit">Photo by Lloyd Mitchell</span></figcaption></figure>
<p><span style="font-weight: 400;">It is estimated that Russo-Elling responded to 25,000 emergency calls throughout her career. She had been preparing to retire six months before she was killed, her family said.</span></p>
<p><span style="font-weight: 400;">Russo-Elling was on duty and buying food near 20th Avenue and Steinway Street in Queens when she was stabbed multiple times in a vicious, unprovoked attack in broad daylight. She was transported to Mount Sinai Queens Hospital in critical condition and died of her injuries at the hospital. According to the FDNY, she is the 1,158th FDNY member to die in the line of duty.</span></p>
<p><span style="font-weight: 400;">The man accused of her killing, 34-year-old Peter Zisopoulos, was escorted out of the New York City Police Department’s 114th Precinct in shackles on Sept. 30 and taken to a hospital for evaluation, according to a spokesperson for the Queens district attorney’s office.</span></p>
<figure id="attachment_106560" aria-describedby="caption-attachment-106560" style="max-width: 2560px" class="wp-caption alignnone"><img loading="lazy" class="size-full wp-image-106560" src="https://www.longislandpress.com/wp-content/uploads/2022/10/Photo-Oct-05-2022-11-28-03-AM-scaled.jpg" alt="FDNY EMS" width="2560" height="1707" srcset="https://www.longislandpress.com/wp-content/uploads/2022/10/Photo-Oct-05-2022-11-28-03-AM-scaled.jpg 2560w, https://www.longislandpress.com/wp-content/uploads/2022/10/Photo-Oct-05-2022-11-28-03-AM-300x200.jpg 300w, https://www.longislandpress.com/wp-content/uploads/2022/10/Photo-Oct-05-2022-11-28-03-AM-1024x683.jpg 1024w, https://www.longislandpress.com/wp-content/uploads/2022/10/Photo-Oct-05-2022-11-28-03-AM-768x512.jpg 768w, https://www.longislandpress.com/wp-content/uploads/2022/10/Photo-Oct-05-2022-11-28-03-AM-1536x1024.jpg 1536w, https://www.longislandpress.com/wp-content/uploads/2022/10/Photo-Oct-05-2022-11-28-03-AM-2048x1365.jpg 2048w, https://www.longislandpress.com/wp-content/uploads/2022/10/Photo-Oct-05-2022-11-28-03-AM-384x256.jpg 384w, https://www.longislandpress.com/wp-content/uploads/2022/10/Photo-Oct-05-2022-11-28-03-AM-900x600.jpg 900w, https://www.longislandpress.com/wp-content/uploads/2022/10/Photo-Oct-05-2022-11-28-03-AM-1600x1067.jpg 1600w" sizes="(max-width: 2560px) 100vw, 2560px" /><figcaption id="caption-attachment-106560" class="wp-caption-text"><span class="image-caption">Alison Russo-Elling&#8217;s casket is brought into the Tilles Center for the funeral service</span><span class="image-credit">Photo by Lloyd Mitchell</span></figcaption></figure>
<p><span style="font-weight: 400;">During the funeral, Adams called Russo-Elling “a hero,” speaking directly to her family about the senseless tragedy of her murder, and said he would “turn pain into purpose” to fight violent crime in the city.</span></p>
<p><span style="font-weight: 400;">“For your loss, I am sorry, and for the violence that has taken so many people in this city,” he said. “We cannot bring her back but today the commissioner and I are promoting her to the rank of captain, and we want you to know what a brave woman your daughter, your mother was.”</span></p>
<p>FDNY members escorted the family in and out of the service. Bagpipes played as members brought the casket in and out of an FDNY EMS ambulance that said &#8220;Alison Russo-Elling Station 49&#8221; on its side.</p>
</div><div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.longislandpress.com/2022/10/05/funeral-ems-lt-alison-russo/" data-a2a-title="Thousands Mourn FDNY EMS Lt. Alison Russo-Elling at Long Island Funeral"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.longislandpress.com%2F2022%2F10%2F05%2Ffuneral-ems-lt-alison-russo%2F&amp;linkname=Thousands%20Mourn%20FDNY%20EMS%20Lt.%20Alison%20Russo-Elling%20at%20Long%20Island%20Funeral" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.longislandpress.com%2F2022%2F10%2F05%2Ffuneral-ems-lt-alison-russo%2F&amp;linkname=Thousands%20Mourn%20FDNY%20EMS%20Lt.%20Alison%20Russo-Elling%20at%20Long%20Island%20Funeral" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_printfriendly" href="https://www.addtoany.com/add_to/printfriendly?linkurl=https%3A%2F%2Fwww.longislandpress.com%2F2022%2F10%2F05%2Ffuneral-ems-lt-alison-russo%2F&amp;linkname=Thousands%20Mourn%20FDNY%20EMS%20Lt.%20Alison%20Russo-Elling%20at%20Long%20Island%20Funeral" title="PrintFriendly" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div><figure class="promo-oneliner newsletter"><span style="margin-right: .1rem; color: #ccc;"><i class="far fa-envelope" aria-hidden="true"></i></span> <span>Sign up for <a href="/newsletter/" target="_blank">Long Island Press’ email newsletters here</a>. Sign up for <a href="https://www.simplecirc.com/subscribe/long-island-press" target="_blank">home delivery of Long Island Press here</a>. Sign up for discounts by <a href="/community-partner/" target="_blank">becoming a Long Island Press community partner here</a>.</span></figure>
</div>
<div class="article-footer">
<div class="addthis_inline_share_toolbox"></div>
<div class="author-meta">
<h3 class="about-the-author">About the Author</h3>
<div class="meta-box author-meta-box">
<img alt='' src='https://www.longislandpress.com/wp-content/uploads/2022/06/22220611_155383441718607_2062982502913409024_n.jpg' srcset='https://www.longislandpress.com/wp-content/uploads/2022/06/22220611_155383441718607_2062982502913409024_n.jpg 2x' class='avatar avatar-128 photo' height='128' width='128' loading='lazy' />
<div class="metadata author-metadata">
<h4 class="meta-name author-name"><a href="https://www.longislandpress.com/author/briana-bonfiglio/">Briana Bonfiglio</a></h4>
<p>Briana Bonfiglio is the Digital Editor of Long Island Press.</p>
<ul class="meta-links author-links">
<li class="meta-fa-envelope"><a href="/cdn-cgi/l/email-protection#4022222f2e2629272c292f003323282e2530332d252429216e232f2d"><i class="far fa-envelope"></i></a></li><li class="meta-fa-twitter"><a href="https://twitter.com/brianabonfiglio"><i class="fab fa-twitter"></i></a></li> </ul>
</div>
</div>
</div>
<div class="comments-container" id="comments-section"> <div data-spotim-module="conversation" data-post-id="106559"></div>
</div>
<a class="comments-opener bkg-pale comments-placeholder" href="https://www.longislandpress.com/2022/10/05/funeral-ems-lt-alison-russo/?comments=show" rel="nofollow"><span class="basic-button bkg-main"><i class="far fa-comment-alt"></i> Join the Conversation</span></a>
</div>
</article>
</div>
<div class="sidebar-section widget-area">
<section class="widget_box widget">
<div class="ad-container card-ad-container">

<div id='div-gpt-ad-1494278047564-0' style='height:250px; width:300px;'>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1494278047564-0'); });
</script>
</div>
</div>
</section>
<section class="featured_jobs_widget widget">
<div class="top-posts featured featured-jobs">
<h2 class="widget-title"><a href="https://jobs.longislandpress.com" target="_blank">Jobs on Long Island</a></h2>
<h4 class="widget-add-yours"><a href="https://jobs.longislandpress.com/list-your-job/" target="_blank" class="basic-button bkg-main"><i class="fas fa-user-plus"></i>Add your job</a></h4>
<ul class="display-posts-listing">
<li class="listing-item article-container cards-design"><span class="title-wrapper"><a class="title featured-job" href="https://jobs.longislandpress.com/2022/10/04/dental-hygienist-wanted-for-wednesday-and-or-thursday-50-per-hour-to-start/" target="_blank"><span class="company-name"><i class="fas fa-building"></i>Steven Langsam DMD</span><span class="job-title">Dental hygienist wanted for Wednesday and/or Thursday 50 per hour to start</span></a></span>
</li>
<li class="listing-item article-container cards-design"><span class="title-wrapper"><a class="title featured-job" href="https://jobs.longislandpress.com/2022/09/06/coordinador-de-operaciones-aeroportuarias-arff/" target="_blank"><span class="job-title">Coordinador de operaciones aeroportuarias / ARFF</span></a></span>
</li>
<li class="listing-item article-container cards-design"><span class="title-wrapper"><a class="title featured-job" href="https://jobs.longislandpress.com/2022/09/21/various-roles-sag-harbor/" target="_blank"><span class="company-name"><i class="fas fa-building"></i>Carissa's Bakery</span><span class="job-title">Various Roles &#8211; Sag Harbor</span></a></span>
</li>
</ul>
<h4 class="widget-add-yours"><a href="https://jobs.longislandpress.com" class="basic-button bkg-main" target="_blank">View all jobs…</a></h4>
</div></section><section class="widget_box widget">
<div class="ad-container card-ad-container">

<div id='div-gpt-ad-1494278047564-1' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1494278047564-1'); });
</script>
</div></div>
</section>
<section id="media_image-3" class="widget widget_media_image"><a href="http://bestoflongisland.com/"><img width="300" height="250" src="https://www.longislandpress.com/wp-content/uploads/2022/10/BOLI_2023_Tile-ad2_300x250_AT.jpg" class="crop-center image wp-image-106480  attachment-full size-full" alt="" loading="lazy" style="max-width: 100%; height: auto;" /></a></section><section class="widget_promo widget standard"><div class="top-posts boli-spotlight">
<h2 class="widget-title"><a href="/category/boli-spotlight/">BoLI Spotlight</a></h2>
<ul class="display-posts-listing"><li class="listing-item article-container cards-design"><a class="image" href="https://www.longislandpress.com/2022/10/05/best-bacon-on-long-island/"><img width="150" height="150" src="https://www.longislandpress.com/wp-content/uploads/2017/06/bacon-150x150.jpg" class="crop-center attachment-thumbnail size-thumbnail wp-post-image" alt="bacon" loading="lazy" /></a> <span class="title-wrapper"><a class="title" href="https://www.longislandpress.com/2022/10/05/best-bacon-on-long-island/">Who Has The Best Bacon Menu Item on Long Island?</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://www.longislandpress.com/2022/09/28/who-is-the-best-chef-on-long-island-2/"><img width="150" height="150" src="https://www.longislandpress.com/wp-content/uploads/2018/04/shutterstock_299406014-150x150.jpg" class="crop-center attachment-thumbnail size-thumbnail wp-post-image" alt="chef" loading="lazy" /></a> <span class="title-wrapper"><a class="title" href="https://www.longislandpress.com/2022/09/28/who-is-the-best-chef-on-long-island-2/">Who is The Best Chef on Long Island?</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://www.longislandpress.com/2022/09/26/voting-begins-october-1-in-best-of-long-island-contest/"><img width="150" height="150" src="https://www.longislandpress.com/wp-content/uploads/2017/09/LOGOBethpageBestofLIgeneric-page-001-150x150.jpg" class="crop-center attachment-thumbnail size-thumbnail wp-post-image" alt="Best of Long Island" loading="lazy" /></a> <span class="title-wrapper"><a class="title" href="https://www.longislandpress.com/2022/09/26/voting-begins-october-1-in-best-of-long-island-contest/">Voting Begins October 1 in Best of Long Island Contest</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://www.longislandpress.com/2022/09/21/who-makes-the-best-appetizer-on-long-island/"><img width="150" height="150" src="https://www.longislandpress.com/wp-content/uploads/2022/09/GettyImages-1322031232-150x150.jpg" class="crop-center attachment-thumbnail size-thumbnail wp-post-image" alt="appetizer" loading="lazy" /></a> <span class="title-wrapper"><a class="title" href="https://www.longislandpress.com/2022/09/21/who-makes-the-best-appetizer-on-long-island/">Who Makes The Best Appetizer on Long Island?</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://www.longislandpress.com/2022/09/14/who-makes-the-best-cheesesteak-on-long-island-2/"><img width="150" height="150" src="https://www.longislandpress.com/wp-content/uploads/2020/10/GettyImages-1212035651-150x150.jpg" class="crop-center attachment-thumbnail size-thumbnail wp-post-image" alt="cheesesteak" loading="lazy" /></a> <span class="title-wrapper"><a class="title" href="https://www.longislandpress.com/2022/09/14/who-makes-the-best-cheesesteak-on-long-island-2/">Who Makes The Best <span class="lgwd">Cheesesteak</span> on Long Island?</a></span></li></ul>
</div></section><section class="widget_promo widget optional"><div class="subscribe-now-box bkg-plain promo-content">
<h2 class="section-title"><a href="/newsletter/"><i class="far fa-envelope"></i>Sign up for our daily Long Island news updates</a></h2>
<p><a href="/newsletter/" class="basic-button bkg-main">Subscribe</a></p>
</div></section><section class="widget_box widget">
<div class="ad-container card-ad-container">

<div id='div-gpt-ad-1591291514378-0' style='width: 300px; height: 600px;'>
<script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1591291514378-0'); });
  </script>
</div>
</div>
</section>
<section class="widget_promo widget optional"><div class="top-posts featured-news">
<h2 class="widget-title">Latest News</h2>
<ul class="display-posts-listing"><li class="listing-item article-container cards-design"><a class="image" href="https://www.longislandpress.com/2022/10/05/funeral-ems-lt-alison-russo/"><img width="150" height="150" src="https://www.longislandpress.com/wp-content/uploads/2022/10/Photo-Oct-05-2022-11-24-28-AM-1-150x150.jpg" class="crop-center attachment-thumbnail size-thumbnail wp-post-image" alt="Photo Oct 05 2022 11 24 28 AM 1" loading="lazy"></a> <span class="title-wrapper"><a class="title" href="https://www.longislandpress.com/2022/10/05/funeral-ems-lt-alison-russo/">Thousands Mourn FDNY EMS Lt. Alison <span class="lgwd">Russo-Elling</span> at Long Island Funeral</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://www.longislandpress.com/2022/10/05/task-force-safety-stretch-limos/"><img width="150" height="150" src="https://www.longislandpress.com/wp-content/uploads/2016/06/traffic-150x150.jpg" class="crop-center attachment-thumbnail size-thumbnail wp-post-image" alt="limos" loading="lazy" /></a> <span class="title-wrapper"><a class="title" href="https://www.longislandpress.com/2022/10/05/task-force-safety-stretch-limos/">Task Force Urges Safety <span class="lgwd">Improvements</span> for Stretch Limos</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://www.longislandpress.com/2022/10/05/return-100m-willem-de-kooning/"><img width="150" height="150" src="https://www.longislandpress.com/wp-content/uploads/2022/10/AP22272004421700-150x150.jpg" class="crop-center attachment-thumbnail size-thumbnail wp-post-image" alt="willem de kooning" loading="lazy" /></a> <span class="title-wrapper"><a class="title" href="https://www.longislandpress.com/2022/10/05/return-100m-willem-de-kooning/">Art Lover Returns $100M Willem de Kooning Piece</a></span></li><li class="listing-item article-container cards-design post-format-link"><a class="image" href="https://www.longislandpress.com/2022/10/04/meet-the-candidates-general-election-jackie-gordon-congressional-district-2/"><img width="150" height="150" src="https://www.longislandpress.com/wp-content/uploads/2022/10/Jackie-Gordon-Thumbnail-1200x675-1-150x150.jpg" class="crop-center attachment-thumbnail size-thumbnail wp-post-image" alt="Jackie Gordon Thumbnail 1200x675 1" loading="lazy"></a> <span class="title-wrapper"><a class="title" href="https://politicsny.com/2022/10/04/meet-the-candidates-general-election-jackie-gordon-congressional-district-2/">Meet the <span class="lgwd">Candidates:</span> General Election <span class="decorator">|</span> Jackie Gordon, <span class="lgwd">Congressional</span> District 2</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://www.longislandpress.com/2022/10/04/cdc-drops-traveler-health-notices/"><img width="150" height="150" src="https://www.longislandpress.com/wp-content/uploads/2022/10/AP22277016338427-150x150.jpg" class="crop-center attachment-thumbnail size-thumbnail wp-post-image" alt="AP22277016338427" loading="lazy"></a> <span class="title-wrapper"><a class="title" href="https://www.longislandpress.com/2022/10/04/cdc-drops-traveler-health-notices/">CDC Drops Traveler Health Notices for Individual Countries</a></span></li></ul>
</div></section> </div>
</div>
</div>
</div>
<div class="component-container popular-in-the-community" style="display:none">
<div class="popularcommunity-container">
<div data-spotim-module="pitc"></div>
</div>
</div>
<div class="component-container related-posts">
<div class="related-posts-footer">
<h2 class="related-title">Related Articles</h2>

<ul class="display-posts-listing"><li class="listing-item article-container cards-design"><a class="image related-posts-true" href="https://www.longislandpress.com/2022/02/17/fdny-firefighter-from-long-beach-dies-of-medical-episode-in-queens/"><img width="300" height="221" src="https://www.longislandpress.com/wp-content/uploads/2022/02/Jesse-Gerhard-Official-Photo-1600x1384-300x221.jpg" class="crop-center attachment-medium size-medium wp-post-image" alt="firefighter from long beach" loading="lazy" srcset="https://www.longislandpress.com/wp-content/uploads/2022/02/Jesse-Gerhard-Official-Photo-1600x1384-300x221.jpg 300w, https://www.longislandpress.com/wp-content/uploads/2022/02/Jesse-Gerhard-Official-Photo-1600x1384-80x60.jpg 80w, https://www.longislandpress.com/wp-content/uploads/2022/02/Jesse-Gerhard-Official-Photo-1600x1384-696x513.jpg 696w, https://www.longislandpress.com/wp-content/uploads/2022/02/Jesse-Gerhard-Official-Photo-1600x1384-570x420.jpg 570w" sizes="(max-width: 300px) 100vw, 300px" /></a> <span class="title-wrapper"><a class="title related-posts-true" href="https://www.longislandpress.com/2022/02/17/fdny-firefighter-from-long-beach-dies-of-medical-episode-in-queens/">FDNY <span class="lgwd">Firefighter</span> from Long Beach Dies of &#8216;Medical Episode&#8217; in Queens</a></span></li><li class="listing-item article-container cards-design"><a class="image related-posts-true" href="https://www.longislandpress.com/2021/09/08/fdny-lieutenant-from-li-who-survived-9-11-collapse-finds-his-spiritual-side/"><img width="300" height="217" src="https://www.longislandpress.com/wp-content/uploads/2021/09/DEC04933-1200x867-300x217.jpg" class="crop-center attachment-medium size-medium wp-post-image" alt="9/11 collapse" loading="lazy" srcset="https://www.longislandpress.com/wp-content/uploads/2021/09/DEC04933-1200x867-300x217.jpg 300w, https://www.longislandpress.com/wp-content/uploads/2021/09/DEC04933-1200x867-324x235.jpg 324w, https://www.longislandpress.com/wp-content/uploads/2021/09/DEC04933-1200x867-696x503.jpg 696w, https://www.longislandpress.com/wp-content/uploads/2021/09/DEC04933-1200x867-581x420.jpg 581w" sizes="(max-width: 300px) 100vw, 300px" /></a> <span class="title-wrapper"><a class="title related-posts-true" href="https://www.longislandpress.com/2021/09/08/fdny-lieutenant-from-li-who-survived-9-11-collapse-finds-his-spiritual-side/">FDNY Lieutenant From LI Who Survived 9/11 Collapse Finds His Spiritual Side</a></span></li><li class="listing-item article-container cards-design"><a class="image related-posts-true" href="https://www.longislandpress.com/2019/10/19/barnshed-brewing-nys-bravest-brewer/"><img width="300" height="227" src="https://www.longislandpress.com/wp-content/uploads/2019/10/FA0E293E-4430-47E2-A009-4971E63D7259-300x227.jpeg" class="crop-center attachment-medium size-medium wp-post-image" alt="FA0E293E 4430 47E2 A009 4971E63D7259" loading="lazy" srcset="https://www.longislandpress.com/wp-content/uploads/2019/10/FA0E293E-4430-47E2-A009-4971E63D7259-300x227.jpeg 300w, https://www.longislandpress.com/wp-content/uploads/2019/10/FA0E293E-4430-47E2-A009-4971E63D7259-80x60.jpeg 80w, https://www.longislandpress.com/wp-content/uploads/2019/10/FA0E293E-4430-47E2-A009-4971E63D7259-696x526.jpeg 696w, https://www.longislandpress.com/wp-content/uploads/2019/10/FA0E293E-4430-47E2-A009-4971E63D7259-556x420.jpeg 556w, https://www.longislandpress.com/wp-content/uploads/2019/10/FA0E293E-4430-47E2-A009-4971E63D7259.jpeg 750w" sizes="(max-width: 300px) 100vw, 300px"></a> <span class="title-wrapper"><a class="title related-posts-true" href="https://www.longislandpress.com/2019/10/19/barnshed-brewing-nys-bravest-brewer/">Barnshed Brewing: NY&#8217;s Bravest Brewer</a></span></li><li class="listing-item article-container cards-design"><a class="image related-posts-true" href="https://www.longislandpress.com/2018/10/20/fdny-chef-joe-chiodi-fires-up-the-famous-meatballers/"><img width="300" height="225" src="https://www.longislandpress.com/wp-content/uploads/2018/10/A814B60D-5163-4B80-8204-D3CBADE66E2F-300x225.jpeg" class="crop-center attachment-medium size-medium wp-post-image" alt="A814B60D 5163 4B80 8204 D3CBADE66E2F" loading="lazy" srcset="https://www.longislandpress.com/wp-content/uploads/2018/10/A814B60D-5163-4B80-8204-D3CBADE66E2F-300x225.jpeg 300w, https://www.longislandpress.com/wp-content/uploads/2018/10/A814B60D-5163-4B80-8204-D3CBADE66E2F-80x60.jpeg 80w, https://www.longislandpress.com/wp-content/uploads/2018/10/A814B60D-5163-4B80-8204-D3CBADE66E2F-265x198.jpeg 265w, https://www.longislandpress.com/wp-content/uploads/2018/10/A814B60D-5163-4B80-8204-D3CBADE66E2F-696x522.jpeg 696w, https://www.longislandpress.com/wp-content/uploads/2018/10/A814B60D-5163-4B80-8204-D3CBADE66E2F-560x420.jpeg 560w" sizes="(max-width: 300px) 100vw, 300px"></a> <span class="title-wrapper"><a class="title related-posts-true" href="https://www.longislandpress.com/2018/10/20/fdny-chef-joe-chiodi-fires-up-the-famous-meatballers/">FDNY Chef Joe Chiodi Fires Up The Famous <span class="lgwd">Meatballers</span></a></span></li></ul>
</div>
</div>
<div class="hero-container sister-sites-container component-container card">
<div class="component-title-section">
<h2 class="section-title">More from our Sister Sites</h2>
</div>
<div class="hero-section sister-sites component-content-section hero-blocks-4">
<article class="article-container cards-design">
<a href="https://www.danspapers.com/2022/10/alec-baldwin-rust-death-lawsuit-settled/"><img width="700" height="457" src="https://www.danspapers.com/wp-content/uploads/2022/01/AlecBaldwinReuters-700x457.jpeg" class="crop-center wp-post-image" alt="Rust actor Alec Baldwin at the 69th Primetime Emmy Awards" loading="lazy" srcset="https://www.danspapers.com/wp-content/uploads/2022/01/AlecBaldwinReuters-700x457.jpeg 700w, https://www.danspapers.com/wp-content/uploads/2022/01/AlecBaldwinReuters-768x502.jpeg 768w, https://www.danspapers.com/wp-content/uploads/2022/01/AlecBaldwinReuters-384x251.jpeg 384w, https://www.danspapers.com/wp-content/uploads/2022/01/AlecBaldwinReuters-900x588.jpeg 900w, https://www.danspapers.com/wp-content/uploads/2022/01/AlecBaldwinReuters.jpeg 1068w" sizes="(max-width: 700px) 100vw, 700px" /></a> <div class="context-box sister-sites-metabox">
<div class="blurb category-label site-label-dans-papers"><a href="https://www.danspapers.com">Dan’s Papers</a></div>
<h2><a href="https://www.danspapers.com/2022/10/alec-baldwin-rust-death-lawsuit-settled/">Alec Baldwin &#8216;Rust&#8217; Shooting Lawsuit Settled, Film <span class="titend">May Resume</span></a></h2>
</div>
</article>
<article class="article-container cards-design">
<a href="https://www.amny.com/news/amazon-suspends-50-workers-after-fire-protest/"><img width="700" height="467" src="https://www.amny.com/wp-content/uploads/2022/10/AP22278576135088-700x467.jpg" class="crop-center wp-post-image" alt="Amazon protest" loading="lazy" srcset="https://www.amny.com/wp-content/uploads/2022/10/AP22278576135088-700x467.jpg 700w, https://www.amny.com/wp-content/uploads/2022/10/AP22278576135088-1200x800.jpg 1200w, https://www.amny.com/wp-content/uploads/2022/10/AP22278576135088-768x512.jpg 768w, https://www.amny.com/wp-content/uploads/2022/10/AP22278576135088-1536x1024.jpg 1536w, https://www.amny.com/wp-content/uploads/2022/10/AP22278576135088-384x256.jpg 384w, https://www.amny.com/wp-content/uploads/2022/10/AP22278576135088-900x600.jpg 900w, https://www.amny.com/wp-content/uploads/2022/10/AP22278576135088-1600x1067.jpg 1600w" sizes="(max-width: 700px) 100vw, 700px" title=""></a> <div class="context-box sister-sites-metabox">
<div class="blurb category-label site-label-amny"><a href="https://www.amny.com">amNY</a></div>
<h2><a href="https://www.amny.com/news/amazon-suspends-50-workers-after-fire-protest/">Amazon suspends at least 50 workers after <span class="titend">fire protest</span></a></h2>
</div>
</article>
<article class="article-container cards-design">
<a href="https://www.noticiali.com/bajo-el-agua-alcalde-decide-cambiar-campamento-para-migrantes-de-orchard-beach-a-randalls-island-debido-a-inundaciones/"><img width="700" height="467" src="https://www.noticiali.com/wp-content/uploads/2022/10/MIGRANT-CAMP-700x467.jpeg" class="crop-center wp-post-image" alt="Orchard Beach" loading="lazy" srcset="https://www.noticiali.com/wp-content/uploads/2022/10/MIGRANT-CAMP-700x467.jpeg 700w, https://www.noticiali.com/wp-content/uploads/2022/10/MIGRANT-CAMP-768x512.jpeg 768w, https://www.noticiali.com/wp-content/uploads/2022/10/MIGRANT-CAMP-384x256.jpeg 384w, https://www.noticiali.com/wp-content/uploads/2022/10/MIGRANT-CAMP-900x600.jpeg 900w, https://www.noticiali.com/wp-content/uploads/2022/10/MIGRANT-CAMP-450x300.jpeg 450w, https://www.noticiali.com/wp-content/uploads/2022/10/MIGRANT-CAMP.jpeg 1200w" sizes="(max-width: 700px) 100vw, 700px" /></a> <div class="context-box sister-sites-metabox">
<div class="blurb category-label site-label-noticia"><a href="https://www.noticiali.com">Noticia</a></div>
<h2><a href="https://www.noticiali.com/bajo-el-agua-alcalde-decide-cambiar-campamento-para-migrantes-de-orchard-beach-a-randalls-island-debido-a-inundaciones/">¡Bajo el agua! Alcalde decide cambiar campamento para migrantes de Orchard Beach a Randall&#8217;s Island debido a <span class="lgwd">inundaciones</span></a></h2>
</div>
</article>
<article class="article-container cards-design">
<a href="https://behindthehedges.com/development-debate-amagansett-handy-lane/"><img width="704" height="500" src="https://behindthehedges.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-05-at-9.49.39-AM-704x500.png" class="crop-center wp-post-image" alt="Amagansett, Development, Handy Lane" loading="lazy" srcset="https://behindthehedges.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-05-at-9.49.39-AM-704x500.png 704w, https://behindthehedges.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-05-at-9.49.39-AM-1024x727.png 1024w, https://behindthehedges.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-05-at-9.49.39-AM-768x545.png 768w, https://behindthehedges.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-05-at-9.49.39-AM-1536x1091.png 1536w, https://behindthehedges.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-05-at-9.49.39-AM-384x273.png 384w, https://behindthehedges.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-05-at-9.49.39-AM-900x639.png 900w, https://behindthehedges.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-05-at-9.49.39-AM-1600x1136.png 1600w" sizes="(max-width: 704px) 100vw, 704px" /></a> <div class="context-box sister-sites-metabox">
<div class="blurb category-label site-label-behind-the-hedges"><a href="https://behindthehedges.com">Behind the Hedges</a></div>
<h2><a href="https://behindthehedges.com/development-debate-amagansett-handy-lane/"><span class="lgwd">Development</span> Debate: Neighbors Try to Stop Amagansett <span class="titend">Project</span></a></h2>
</div>
</article>
</div>
</div>
<footer class="site-footer">
<nav class="footer-nav-menu"><ul>
<li>
<a class="" href="/contact-us" target="">
<span>Contact Us</span>
</a>
</li>
<li>
<a class="" href="/subscribe" target="">
<span>Subscribe</span>
</a>
</li>
<li>
<a class="" href="https://www.bestoflongisland.com/" target="_blank">
<span>Best of Long Island</span>
</a>
</li>
<li>
<a class="" href="/home-pros/" target="">
<span>Home Pros</span>
</a>
</li>
<li>
<a class="" href="/jobs" target="">
<span>Jobs</span>
</a>
</li>
<li class="nav-menu-social-links social-links nav-menu-icon-row">
<a href="https://www.facebook.com/longislandpress" target="_blank" title="Facebook">
<i class="fab fa-facebook-f" aria-hidden="true" aria-label="Facebook"></i></a>
<a href="https://twitter.com/longislandpress" target="_blank" title="Twitter">
<i class="fab fa-twitter" aria-hidden="true" aria-label="Twitter"></i></a>
<a href="https://www.youtube.com/user/longislandpress" target="_blank" title="Youtube">
<i class="fab fa-youtube" aria-hidden="true" aria-label="Youtube"></i></a>
<a href="https://www.instagram.com/longislandpress/" target="_blank" title="Instagram">
<i class="fab fa-instagram" aria-hidden="true" aria-label="Instagram"></i></a>
</li>
</ul></nav>
<nav class="site-info"><ul>
<li class="copyright">
<a href="https://www.schnepsmedia.com/" target="_blank">
<span>© Long Island Press 2022.</span> <span>Schneps Media.</span>
</a>
</li>
<li class="">
<a href="/privacy-policy/" target="">
<span>Privacy Policy</span>
</a>
</li>
<li class="">
<a href="/terms/" target="">
<span>Terms of Use</span>
</a>
</li>
</ul></nav>
</footer>
</div> 
<nav id="theStickyNavBar" class="sticky sticky-fa sticky-bottom-bar" role="navigation">
<ul>
<li class="hamburger">
<span class="sticky-item">
<i class="fas fa-bars opener"></i>
Sections
</span>
</li>
<li class="">
<a class="sticky-item" href="/home-pros/" target="" title="">
<i class="fas fa-tools"></i> Home Pros </a>
</li>
<li class="">
<a class="sticky-item" href="/contact-us/" target="" title="">
<i class="fas fa-phone"></i> Contact </a>
</li>
<li class="">
<a class="sticky-item" href="https://behindthehedges.com/" target="_blank" title="">
<i class="fas fa-sign"></i> Real Estate </a>
</li>
<li class="">
<a class="sticky-item" href="https://jobs.longislandpress.com/" target="_blank" title="">
<i class="fas fa-user-tie"></i> Jobs </a>
</li>
</ul>
</nav>
<div id='pico-widget-container'></div><script type='text/javascript' src='https://www.longislandpress.com/wp-content/plugins/home-pros-directory/assets/js/main.js?ver=1.1.9.4.0.5' id='blankslate-main-js'></script>
<script type='text/javascript' id='bs-custom-muut-js-extra'>
/* <![CDATA[ */
var muut_ajax = {"base_slug":"home-pros","api":"53877b7fe4b041e7f7a30676","mapping":{"Renovation":["contractors"],"Exteriors":["contractors"],"Plumbing":["plumbing"],"Conversion":["contractors"],"Doors & Windows":["doors-and-windows"],"Bath & Kitchen":["bathrooms","kitchens"],"Dept. of Buildings (DOB)":["real-estate-development-and-title-companies"],"Home Buying":["real-estate-agents"],"Roofing":["roofers"],"Heating and Cooling":["heating-ventilating-and-air-conditioning"],"Landscaping":["landscaping-and-gardeners","tree-service","deck-and-patio"],"Doors":["doors-and-windows"],"General Contractors":["contractors"],"architects":["architects"],"interior-designers":["interior-design"],"landscapers-and-lawn-services":["landscaping-and-gardeners","tree-service","deck-and-patio"],"flooring-and-carpet-installers":["carpet-and-flooring"],"tile-stone-professionals":["cemeteries"],"electricians":["electricians"],"painters":["painting"],"chimney-fireplaces":["fences-fireplaces-and-garage-doors"],"carpenters":["carpenters"],"stair-building-repair-specialists":["churches"],"closet-cabinet-specialists":["kosher"],"metal-ironwork-professionals":["metals","welding"],"renewable-energy":["renewable-energy"],"home-security":["security-and-safety"],"home-automation":["automation-and-control-systems"],"expeditors":["real-estate-development-and-title-companies"],"mortgage":["loans-and-mortgages"],"real-estate-brokerages":["petroleum"],"real-estate-agents":["real-estate-agents"],"lawyers":["legal"],"appraisers-inspectors":["real-estate-appraiser"],"insurance-agents":["insurance"],"professional-cleaners":["professional-cleaning"],"exterminators":["pest-control"],"movers-and-storage-services":["movers","storage"],"rubbish-removal-companies":["sewer","water-and-waste-management"],"locksmiths":["hardware-and-services"],"property-managers":["property-management"],"tax-and-accounting-services":["accounting-and-bookkeeping","financial-planning-and-investments"]}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.longislandpress.com/wp-content/plugins/home-pros-directory/assets/js/bs-custom-muut.js?ver=1.1.9.4.0.5' id='bs-custom-muut-js'></script>
<script type='text/javascript' id='theme-js-js-extra'>
/* <![CDATA[ */
var ajax_controller = {"ajax_url":"https:\/\/www.longislandpress.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.longislandpress.com/wp-content/themes/schnepstheme/build/bundle.8fe6ac08.js' id='theme-js-js'></script>
<script type='text/javascript' src='https://www.longislandpress.com/wp-content/themes/schnepstheme-lipress/build/bundle.4d55c390.js' id='child-theme-js-js'></script>
<div class="footer-ad-code">
<div id='div-gpt-ad-1547068129808-0' style='height:1px; width:1px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1547068129808-0'); });
</script>
</div>
</div>
</body>
</html>
